Magento 2.3 and below

Recently, we updated our MariaDB version from 10.3 and 10.4 to 10.5 at all Shared and Cloud servers. As Magento doesn’t officially support MariaDB 10.5 yet, if you try installing it via our Auto Installer, you will see an error like this:

Error: The selected version 2.3.6 is not compatible with the selected install location.Requirements:mariadb 10.2-10.3.99 (detected: 10.5.12)

No worries, we know how to proceed! Just follow the steps below and you’ll have Magento installed on your hosting account in no time!

STEP 1 - Install Magento manually

The first thing you will need to do is to install Magento manually, for that you can refer to this comprehensive tutorial - How to Install Magento 2.x.x Manually.

STEP 2 - Edit the configuration file

After you got Magento installed, you will need to open app/etc directory and open di.xml file for editing (simply double-click on it):

Once there, you will need to find this line:

<item name="MariaDB-(10.2-10.4)" xsi:type="string">^10\.[2-4]\.</item>

And replace it with this one:

<item name="MariaDB-(10.2-10.5)" xsi:type="string">^10\.[2-5]\.</item>

An example can be found here: Update di.xml to support MariaDB 10.5.x #33111

That’s it! Once you save the changes, your Magento website will start working properly

NOTES:

  • A permanent fix will be released later. For now, kindly proceed with these steps for Magento installation

  • According to the official website, the end of software support date for Magento Commerce 2.3 has been extended to April 2022 due to impacts from COVID-19. This means, that after April 2022, Magento 2.3 and below versions will no longer be supported and are not recommended to use

Magento 2.4 and above

Magento 2.4 and above can only be used on VPS plans due to Elasticsearch being one of the requirements - and it is available on VPS plans only.

Did this answer your question?